<!DOCTYPE html>
<html lang="en-US">
	<head>
				<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, minimal-ui">
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="OiL2jpCIpGq42RwIrj5Q9M6263Y62yCkcxi6bEZRQfo" />
<meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB" />
		<script>
			window.dataLayer = window.dataLayer || [];
						dataLayer.push({"pageType":"post","postCategory":["ecoflow","sponsored-post"]});
					</script>
				<script src="https://electrek.co/wp-content/themes/9to5-2015/assets/js/adsbygoogle.js"></script>

               <!-- Google Tag Manager -->
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
				new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
				j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
				'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-5P9GSSX');</script>
		<!-- End Google Tag Manager -->
					<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
		<link rel="apple-touch-icon" href="/apple-touch-icon.png" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" sizes="192x192" href="/wp-content/themes/9to5-2015/images/favicons/electrek/icon-192x192.png">
		<link rel="manifest" href="/wp-content/themes/9to5-2015/images/favicons/electrek/site.webmanifest">
	
	<!-- This site is optimized with the Yoast SEO Premium plugin v16.7 (Yoast SEO v16.7) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Don&#039;t miss these Black Friday deals on EcoFlow Power Stations - Electrek</title>
	<meta name="description" content="An outline of some substantial discounts from EcoFlow for Black Friday 2021, including deals on power stations and bundles." />
	<link rel="canonical" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" />
	<meta property="og:description" content="An outline of some substantial discounts from EcoFlow for Black Friday 2021, including deals on power stations and bundles." />
	<meta property="og:url" content="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/" />
	<meta property="og:site_name" content="Electrek" />
	<meta property="article:publisher" content="https://www.facebook.com/electrekco" />
	<meta property="article:published_time" content="2021-11-10T22:15:30+00:00" />
	<meta property="article:modified_time" content="2021-11-10T22:15:31+00:00" />
	<meta property="og:image" content="https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?resize=1200%2C628&#038;quality=82&#038;strip=all&#038;ssl=1" />
	<meta property="og:image:width" content="4350" />
	<meta property="og:image:height" content="2500" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?resize=1200%2C628&amp;quality=82&amp;strip=all&amp;ssl=1" />
	<meta name="twitter:creator" content="@electrekco" />
	<meta name="twitter:site" content="@electrekco" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Sponsored Post" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://electrek.co/#organization","name":"Electrek.co","url":"https://electrek.co/","sameAs":["https://www.facebook.com/electrekco","https://www.instagram.com/electrek.co/","https://youtube.com/c/electrekco","https://twitter.com/electrekco"],"logo":{"@type":"ImageObject","@id":"https://electrek.co/#logo","inLanguage":"en-US","url":"https://electrek.co/wp-content/uploads/sites/3/2018/09/cropped-electrek-logo11.png","contentUrl":"https://electrek.co/wp-content/uploads/sites/3/2018/09/cropped-electrek-logo11.png","width":480,"height":100,"caption":"Electrek.co"},"image":{"@id":"https://electrek.co/#logo"}},{"@type":"WebSite","@id":"https://electrek.co/#website","url":"https://electrek.co/","name":"Electrek","description":"EV and Tesla News, Green Energy, Ebikes, and more","publisher":{"@id":"https://electrek.co/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://electrek.co/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#primaryimage","inLanguage":"en-US","url":"https://electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV\u7b2c\u4e8c\u7248\u7b2c\u4e94\u6b21\u4fee\u6539.jpg?quality=82&strip=all","contentUrl":"https://electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV\u7b2c\u4e8c\u7248\u7b2c\u4e94\u6b21\u4fee\u6539.jpg?quality=82&strip=all","width":4350,"height":2500},{"@type":"WebPage","@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#webpage","url":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/","name":"Don't miss these Black Friday deals on EcoFlow Power Stations - Electrek","isPartOf":{"@id":"https://electrek.co/#website"},"primaryImageOfPage":{"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#primaryimage"},"datePublished":"2021-11-10T22:15:30+00:00","dateModified":"2021-11-10T22:15:31+00:00","description":"An outline of some substantial discounts from EcoFlow for Black Friday 2021, including deals on power stations and bundles.","breadcrumb":{"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/"]}]},{"@type":"BreadcrumbList","@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://electrek.co/"},{"@type":"ListItem","position":2,"name":"Don&#8217;t miss these Black Friday deals from EcoFlow, offering as much as $650 off"}]},{"@type":["Article","NewsArticle"],"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#article","isPartOf":{"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#webpage"},"author":{"@id":"https://electrek.co/#/schema/person/a67cd1b42306615fcafc69c18578cdda"},"headline":"Don&#8217;t miss these Black Friday deals from EcoFlow, offering as much as $650 off","datePublished":"2021-11-10T22:15:30+00:00","dateModified":"2021-11-10T22:15:31+00:00","mainEntityOfPage":{"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#webpage"},"wordCount":1081,"commentCount":0,"publisher":{"@id":"https://electrek.co/#organization"},"image":{"@id":"https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#primaryimage"},"thumbnailUrl":"https://electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV\u7b2c\u4e8c\u7248\u7b2c\u4e94\u6b21\u4fee\u6539.jpg?quality=82&strip=all","articleSection":["News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#respond"]}],"copyrightYear":"2021","copyrightHolder":{"@id":"https://925.co/#organization"},"accessibilityFeature":["tableOfContents"]},{"@type":"Person","@id":"https://electrek.co/#/schema/person/a67cd1b42306615fcafc69c18578cdda","name":"Sponsored Post","image":{"@type":"ImageObject","@id":"https://electrek.co/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/85700b4b3b5d6089c388df52d53a7fcc?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/85700b4b3b5d6089c388df52d53a7fcc?s=96&d=identicon&r=g","caption":"Sponsored Post"},"url":"https://electrek.co/author/sponsoredpostz/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//9to5mac-com.videoplayerhub.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Electrek &raquo; Feed" href="https://electrek.co/feed/" />
<link rel="alternate" type="application/rss+xml" title="Electrek &raquo; Comments Feed" href="https://electrek.co/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Electrek &raquo; Don&#8217;t miss these Black Friday deals from EcoFlow, offering as much as $650 off Comments Feed" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/electrek.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://electrek.co/_static/??-eJyNjkEOwiAQRS8knVYDhoXxLBQmih2gYcYYbi9NXLQ7ly//veTDZ1Uxe3oHZPDMECILzFT8oijO1dUGLI1wSDEPXTjBvngxJAzRIWHCLAdYyTWsivDhfPsv79ueD5EvWTZHnn1jsFK0Oo+TBseM8jvv6pJKwC26p9tkLkYba6/jF2eeVHA=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%7CQuestrial&#038;ver=5.8.2' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://electrek.co/_static/??-eJyVjs0KgzAQhF+ocZOKKR5KnyUkW02bH3E3iG/fqLTQo7eBmflmYJmEzYkxMfCIEQl6zp24StWBIUImsERAwdt3U9UFzjTEnjjX4zUgNdGnX80nG4rDw3eGRl9B/5EvORYxhTL4RPBCnky9oGTTQsyuVCws3g3bEqGZ7XgM7lIcjnjOO8lt5Ee8K93qTvf9TX4AExRqMQ==' type='text/css' media='all' />
<script type="text/javascript" src="https://electrek.co/_static/??-eJx9jEEOwiAQRS8kTLEBw6LxLKRMFHSGCoOmt5cYF65MfvI27314bSrxeu8RG+SxR8e6f6Epsc7tAP8kRelSg+CvvBYWZAG5Io3ES7HqOBkLoTWUz8cTOZYKMdQblYijPNNi3Oys8/405TccVTbM" ></script><script src='//9to5mac-com.videoplayerhub.com/gallery.js?ver=5.8.2' id='ninetofive-blockthrough-js'></script>
<link rel="https://api.w.org/" href="https://electrek.co/wp-json/" /><link rel="alternate" type="application/json" href="https://electrek.co/wp-json/wp/v2/posts/201494" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://electrek.co/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://electrek.co/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://wp.me/pa0wC0-QpU' />
<link rel="alternate" type="application/json+oembed" href="https://electrek.co/wp-json/oembed/1.0/embed?url=https%3A%2F%2Felectrek.co%2F2021%2F11%2F10%2Fportable-battery-black-friday-deals-ecoflow%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://electrek.co/wp-json/oembed/1.0/embed?url=https%3A%2F%2Felectrek.co%2F2021%2F11%2F10%2Fportable-battery-black-friday-deals-ecoflow%2F&#038;format=xml" />
<!-- Stream WordPress user activity plugin v3.7.0 -->
	<script src="https://assets.a-mo.net/js/adapter.js"></script>
	<script type='text/javascript' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js' async></script>
	<script type='text/javascript' src='https://electrek.co/wp-content/themes/9to5-2015/assets/js/vendor/prebid1.20.0.js' async></script>
	<script>
	!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
	</script>
	<script>
		window.googletag = window.googletag || {};
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
	</script>

	<script type='text/javascript'>
	googletag.cmd.push(function() {
		googletag.defineSlot( '/1049447/Electrek_Signal_1x1', [1, 1], 'div-gpt-ad-signal' ).addService(googletag.pubads());
		googletag.enableServices();
	});
</script>
	<script type="text/javascript">
	var ninetofiveHeaderBidderData = {
		districtmTag: 13893421,
		districtmDmxTag: 242609,
		sovrn: [{"sizes":[[300,250]],"below_the_fold_id":581792},{"sizes":[[728,90]],"above_the_fold_id":581790,"below_the_fold_id":581793},{"sizes":[[970,250]],"above_the_fold_id":581791,"below_the_fold_id":581832},{"sizes":[[970,90]],"above_the_fold_id":581838,"below_the_fold_id":581839}],
		openxUnit: 538489180,
		appnexus: [{"below_the_fold_sizes":[[728,90],[970,90],[970,250],[300,250]],"above_the_fold_sizes":[[728,90],[970,90],[970,250]],"below_the_fold_id":13866598,"above_the_fold_id":13866595}]	};

	var aboveTheFold = true;
	/**
	 *  Build ad units from bidding partners.
	 *
	 * @param {string}  slotID       The slot ID.
	 * @param {array}   sizes        The default sizes.
	 * @param {boolean} aboveTheFold Is the ad above the fold?
	 */
	var ninetofiveGetHeaderBidderAdUnits = function( slotID, sizes, aboveTheFold ) {
		adUnits = [];

		// District M
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtm',
				params: {
					placementId: ninetofiveHeaderBidderData.districtmTag
				}
			} ]
		} );

		// District M DMX
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'districtmDMX',
				params: {
					dmxid: ninetofiveHeaderBidderData.districtmDmxTag,
					memberid: 101574
				}
			} ]
		} );

		// Sovrn
		ninetofiveHeaderBidderData.sovrn.forEach( function( asovrn ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: { sizes: asovrn.sizes } },
				bids: [	{
					bidder: 'sovrn',
					params: {
						tagid: ( aboveTheFold && asovrn.above_the_fold_id ) ?
							asovrn.above_the_fold_id :
							asovrn.below_the_fold_id
					}
				} ]
			} );

		} );
				// OpenX
		adUnits.push( {
			code: slotID,
			mediaTypes: { banner: { sizes: sizes } },
			bids: [	{
				bidder: 'openx',
				params: {
					unit: ninetofiveHeaderBidderData.openxUnit,
					delDomain: 'nineto5mac-d.openx.net'
				}
			} ]
		} );
		
		// AppNexus
		ninetofiveHeaderBidderData.appnexus.forEach( function( anapnexus ) {
			adUnits.push( {
				code: slotID,
				mediaTypes: { banner: {
					sizes: aboveTheFold ? anapnexus.above_the_fold_sizes : anapnexus.below_the_fold_sizes
				} },
				bids: [	{
					bidder: 'appnexus',
					params: {
						placementId: ( aboveTheFold && anapnexus.above_the_fold_id ) ?
							anapnexus.above_the_fold_id :
							anapnexus.below_the_fold_id
					}
				} ]
			} );
		} );

		return adUnits;
	};
	</script>
	<link rel="mask-icon" color="#7CCEFF" href="https://electrek.co/wp-content/themes/9to5-2015/images/electrek-e.svg"><link rel="amphtml" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/amp/">			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<meta name="msapplication-TileImage" content="https://electrek.co/wp-content/uploads/sites/3/2017/03/electrek.png?w=256" />

	<style>
		.th00598ad7 { padding: 10px 0; text-align: center; background: url('https://electrek.co/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; min-height: 120px; }
		@media (min-width: 1049px) {
			.th00598ad7 { 
				min-height: 270px; 
			}
		}

		.th00598ad7 .inlinead { background-color: transparent; min-height: 1px; }
		.th00598ad7 .inlinead > div { background-color: transparent; padding: 0; }

		.color-scheme-electrek .th00598ad7 { background-color: #939598; }

		.ad { margin: 0 auto; }

		@media (min-width: 0px) and (max-width: 767px) { .two-up-ads { display: none; } }

		.two-up-ads, .post-leaderboard { box-sizing: border-box; width: 100%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; background-color: #ECECED; padding: 25px 0; }
		.two-up-ads .ad-1, .two-up-ads .ad-2, .post-leaderboard .ad-1, .post-leaderboard .ad-2 { display: inline-block; width: 300px; height: 250px; overflow: hidden; }
		.two-up-ads .ad-1, .post-leaderboard .ad-1 { box-sizing: border-box; width: 50%; float: left; padding-left: 0.83333%; padding-right: 0.83333%; text-align: right; }
		.two-up-ads .ad-2, .post-leaderboard .ad-2 { box-sizing: border-box; width: 50%; float: right; padding-left: 0.83333%; padding-right: 0.83333%; text-align: left; padding-left: 40px; }

		@media (min-width: 0px) and (max-width: 767px) { .post-leaderboard img { width: 100%; } }

		.post-leaderboard > * { margin: 0 auto; text-align: center; display: block; }

		/** inline ads **/
		.th4b875ebd { background: url('https://electrek.co/wp-content/themes/9to5-2015/images/top-leaderboard-bg.png') repeat center; max-width: 100%; overflow: hidden; text-align: center; }\
		.th4b875ebd > div, .th4b875ebd > ins { padding: 20px 0; margin: 0 auto; }
		.darkmode--activated .th00598ad7,
		.darkmode--activated .th4b875ebd,
		.darkmode--activated .inlinead {
			background: url('https://electrek.co/wp-content/themes/9to5-2015/images/top-leaderboard-bg-dark.png') repeat center;
			isolation: isolate;
		}
		@media only screen and (min-width: 768px) { .th4b875ebd > div, .th4b875ebd > ins { display: block; padding: 25px 10px 25px 0; }

		.post-body .th4b875ebd { background-color: transparent; }

		.th5a2a8276 { width: 300px; min-height: 250px; isolation: isolate; }
		@media (min-device-width: 320px) and (max-device-width: 479px) { .th5a2a8276 { width: 300px; min-height: 250px; } }
		@media (min-device-width: 480px) and (max-device-width: 767px) { .th5a2a8276 { width: 300px; min-height: 250px; } }
		@media (min-width: 768px) { .th5a2a8276 { float: right; margin-left: 20px; width: 336px; min-height: 280px; } }
		@media (min-width: 1000px) {
			.th5a2a8276 { margin: 0 -105px 20px 20px; }
			.aside-post .th5a2a8276 { margin-top: 20px; }
		}

		.th94e685af { line-height: 0; max-width: 300px; position: relative; }
		.th94e685af h3 { background: rgba(0, 0, 0, 0.7); bottom: 0; box-sizing: border-box; color: #fff; font-size: 1.17em; font-weight: 400; line-height: 1.3; margin: 0 0; padding: 0.25em 0.5em; position: absolute; text-align: left; width: 100%; }
		.post-body .th94e685af h3 { font-size: 1em; }
		@media (min-width: 768px) { .post-body .th94e685af { float: right; margin-left: 20px; width: 300px; height: 250px; } }
		@media (min-width: 1000px) { .post-body .th94e685af { margin: 0 -105px 20px 20px; } }

		.th2b6fa0d7 .th94e685af { margin: 0 auto; }
		.thdee9411c { cursor: pointer }
	</style>
<style type="text/css" id="wp-custom-css">#bbp-user-body #two-factor-options ,
#bbp-user-body  h3,
#bbp-user-body .form-table {
	display: none;
}

fieldset.bbp-form {
  min-width: 100%;
}

.bbp-form input#bbp_topic_title,
.bbp-form input#bbp_topic_tags {
  max-width: 100%;
}

#bbpress-forums .status-closed a {
	color: #0d4d7c;
}

#bbpress-forums .status-closed {
	color: #000;
}

.forum_wrapper .fluid-width-video-wrapper .embed-youtube, .forum_wrapper span.embed-youtube {
	margin-left: 0;
	margin-right: 0;
}

.feed-title-bar .icon-google-plus {
	display: none;
}

.wp-block-image.size-large {
}

.wp-block-image img {
	height: auto;
}
.wp-block-media-text
.wp-block-media-text__media img {
	height: auto;
	max-width: 100%;
	width: 100%;
	margin-left: 0;
}

.tax-ninetofive_guides .currently-reading, .tax-ninetofive_guides .news-feed-header {
    min-height: 27px;
		width: 100%;
}

.share-customize-link {
  display: none;
}</style>
		<script>
			document.documentElement.className = document.documentElement.className.replace('no-js', " ");
			document.documentElement.className += ' js ';
		</script>
	</head>
		<body class="post-template-default single single-post postid-201494 single-format-standard wp-embed-responsive color-scheme-electrek infinite-scroll">
					<!-- Google Tag Manager (noscript) -->
		<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5P9GSSX"
		                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<!-- End Google Tag Manager (noscript) -->
			
			<div></div>
			<header class="site-header js-header-normal" id="js-site-header">
				<div class="site-header-inner">

					<div class="header-logo">
						<a href="https://electrek.co/" rel="home">
							<img src="https://electrek.co/wp-content/uploads/sites/3/2018/10/cropped-new-electrek-logo.png" alt="" />
						</a>
						<button aria-expanded="false" aria-controls="js-site-switcher" id="js-button-switcher" class="js-button button-site-switcher">
									<svg class="ninetofive-icon chevron-down js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-chevron-down"/>
		</svg>
											<svg class="ninetofive-icon chevron-up js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-chevron-up"/>
		</svg>
									<span class="screen-reader-text">Switch site</span>
						</button>
					</div>
					<!-- .header-logo -->

					<nav id="primary-menu" class="primary-menu">
						<button class="js-mobile-menu-prev js-button" id="js-mobile-menu-prev" data-direction="1">
									<svg class="ninetofive-icon chevron-left " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-chevron-left"/>
		</svg>
								</button>
						<button class="js-mobile-menu-next js-button" id="js-mobile-menu-next" data-direction="-1">
									<svg class="ninetofive-icon chevron-right " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-chevron-right"/>
		</svg>
								</button>
						<ul id="menu-guides" class="primary-menu-ul"><li id="menu-item-123190" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_featured menu-item-123190"><a href="https://electrek.co/feature/exclusives/">Exclusives</a></li>
<li id="menu-item-38420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38420"><a href="https://electrek.co/guides">Autos</a>
<ul class="sub-menu">
	<li id="menu-item-75456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75456"><a href="https://electrek.co/best-electric-vehicle-prices/">Electric Vehicle Price Guide – best prices for dealers in the US</a></li>
	<li id="menu-item-38424" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38424"><a href="https://electrek.co/guides/tesla/">Tesla</a></li>
	<li id="menu-item-162154" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162154"><a href="https://electrek.co/guides/ford/">Ford</a></li>
	<li id="menu-item-38427" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38427"><a href="https://electrek.co/guides/gm/">GM</a></li>
	<li id="menu-item-75450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75450"><a href="https://electrek.co/guides/bmw/">BMW</a></li>
	<li id="menu-item-70910" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-70910"><a href="https://electrek.co/guides/jaguar/">Jaguar</a></li>
	<li id="menu-item-163698" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-163698"><a href="https://electrek.co/guides/vw/">VW</a></li>
	<li id="menu-item-164939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164939"><a href="https://electrek.co/guides/daimler/">Daimler/Mercedes</a></li>
	<li id="menu-item-38428" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38428"><a href="https://electrek.co/guides/hyundai/">Hyundai</a></li>
	<li id="menu-item-38436" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38436"><a href="https://electrek.co/guides/nissan/">Nissan</a></li>
	<li id="menu-item-164825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164825"><a href="https://electrek.co/guides/Toyota/">Toyota</a></li>
</ul>
</li>
<li id="menu-item-38421" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38421"><a href="https://electrek.co/guides">Alt. Transport</a>
<ul class="sub-menu">
	<li id="menu-item-66671" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-66671"><a href="https://electrek.co/guides/ebikes/">Ebikes</a></li>
	<li id="menu-item-76300" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76300"><a href="https://electrek.co/guides/electric-motorcycle/">Electric Motorcycles</a></li>
	<li id="menu-item-38439" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38439"><a href="https://electrek.co/guides/bus/">Bus</a></li>
	<li id="menu-item-38450" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38450"><a href="https://electrek.co/guides/hyperloop/">Hyperloop</a></li>
</ul>
</li>
<li id="menu-item-38422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38422"><a href="https://electrek.co/guides">Autonomy</a>
<ul class="sub-menu">
	<li id="menu-item-38445" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38445"><a href="https://electrek.co/guides/tesla-autopilot/">Tesla Autopilot</a></li>
	<li id="menu-item-38446" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38446"><a href="https://electrek.co/guides/cruise-automation/">Cruise Automation</a></li>
	<li id="menu-item-38447" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38447"><a href="https://electrek.co/guides/uber/">Uber</a></li>
	<li id="menu-item-38448" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-38448"><a href="https://electrek.co/guides/waymo/">Waymo</a></li>
</ul>
</li>
<li id="menu-item-38423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-38423"><a href="https://electrek.co/guides">Energy</a>
<ul class="sub-menu">
	<li id="menu-item-105256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105256"><a href="https://electrek.co/guides/egeb/">Green Energy</a></li>
	<li id="menu-item-105519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105519"><a href="https://electrek.co/guides/climate-crisis-weekly/">Climate</a></li>
</ul>
</li>
<li id="menu-item-151073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151073"><a href="https://electrek.co/shop">Tesla Shop</a></li>
</ul>					</nav>
					<!-- .primary-menu -->

					<div class="header-right-area">

						<button class="main-menu-toggle js-button" id="js-main-menu-toggle" aria-expanded="false" aria-controls="primary-menu">
									<svg class="ninetofive-icon hamburger js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-hamburger"/>
		</svg>
											<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-cross"/>
		</svg>
									<span class="screen-reader-text">Toggle main menu</span>
						</button>

						<div class="header-social" id="js-header-social">
							<a href="https://youtube.com/c/electrekco" title="View 9to5 on YouTube">
		<svg class="ninetofive-icon youtube " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-youtube"/>
		</svg>
		</a>
<a href="https://www.facebook.com/electrekco/" title="Like us on Facebook">
		<svg class="ninetofive-icon facebook " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-facebook"/>
		</svg>
		</a>
<a href="http://twitter.com/electrekco" title="Follow us on Twitter">
		<svg class="ninetofive-icon twitter " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-twitter"/>
		</svg>
		</a>
<a href="https://www.instagram.com/electrek.co/" title="Follow us on Instagram">
		<svg class="ninetofive-icon instagram " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-instagram"/>
		</svg>
		</a>
<a href="https://itunes.apple.com/us/podcast/electrek/id1320055779" title="Subscribe to our weekly podcast">
		<svg class="ninetofive-icon podcast " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-podcast"/>
		</svg>
		</a>
<div class="header-social-more" id="js-header-social-more" aria-hidden="true"><a href="https://apple.news/TDaZAAzogTHK5rrJYn3D6eQ" title="View 9to5 on Apple News">
		<svg class="ninetofive-icon applenews " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-applenews"/>
		</svg>
		</a>
<a href="https://b.smartnews.be/r/3p2BcxbJznlh4Xi4" title="View 9to5 on SmartNews">
		<svg class="ninetofive-icon smartnews " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-smartnews"/>
		</svg>
		</a>
<a href="https://flipboard.com/@electrek" title="View 9to5 on FlipBoard">
		<svg class="ninetofive-icon flipboard " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-flipboard"/>
		</svg>
		</a>
<a href="https://www.linkedin.com/company/electrek" title="View 9to5 on LinkedIn">
		<svg class="ninetofive-icon linkedin " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-linkedin"/>
		</svg>
		</a>
<a href="https://electrek.co/push/" title="Signup for Safari Notifications">
		<svg class="ninetofive-icon pushup " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-pushup"/>
		</svg>
		</a>
<a href="https://eepurl.com/bTzCKT" title="Signup for our email list">
		<svg class="ninetofive-icon email " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-email"/>
		</svg>
		</a>
</div>							<button aria-expanded="false" aria-controls="js-header-social-more" id="js-button-social" class="js-button button-social-toggle">
										<svg class="ninetofive-icon dots-expand " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-dots-expand"/>
		</svg>
										<span class="screen-reader-text">More social networks</span>
							</button>
						</div>
						<!-- .header-social -->

						<div class="header-icon-links">
							
<a href='https://electrek.co/contact-electrek/' class='has-tooltip'>		<svg class="ninetofive-icon feedback " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-feedback"/>
		</svg>
		<span class='header-tooltip'>Submit a Tip/Contact Us</span></a>
</li>
						</div>
						<!-- .header-icon-links -->
							<button id="dark-mode-toggle" class="button-darkmode-toggle" onclick="darkmode.toggle();">
		 		<svg class="ninetofive-icon dark-mode js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-dark-mode"/>
		</svg>
				<span class="screen-reader-text">Toggle dark mode</span>
	</button>
						<div class="header-search">
							
<form role="search" class="search-form" method="get" action="https://electrek.co/" id="js-search-form">
	<label class="search-label">
		<span class="screen-reader-text">Search</span>
		<input type="search" placeholder="search" name="s" class="searchInput" value="">
	</label>
	<button type="submit" class="search-submit">
				<svg class="ninetofive-icon search " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-search"/>
		</svg>
				<span class="screen-reader-text">Search</span>
	</button>
</form>
							<button aria-expanded="false" aria-controls="js-search-form" id="js-button-search" class="js-button button-search-toggle">
										<svg class="ninetofive-icon search js-regular-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-search"/>
		</svg>
												<svg class="ninetofive-icon cross js-expanded-icon" aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-cross"/>
		</svg>
										<span class="screen-reader-text">Toggle search</span>
							</button>
						</div>
						<!-- .header-search -->

					</div>
					<!-- .header-right-area -->

				</div>
				<!-- .site-header-inner -->

				<div class="site-switcher" id="js-site-switcher" aria-hidden="true">
					<ul class="site-switcher-list">
<li><a href='https://9to5mac.com/'>		<svg class="ninetofive-icon ninetofive-mac " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-ninetofive-mac"/>
		</svg>
		<span class='screen-reader-text'>9to5Mac</span></a></li>
</li>

<li><a href='https://9to5google.com/'>		<svg class="ninetofive-icon ninetofive-google " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-ninetofive-google"/>
		</svg>
		<span class='screen-reader-text'>9to5Google</span></a></li>
</li>

<li><a href='https://9to5toys.com'>		<svg class="ninetofive-icon ninetofive-toys " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-ninetofive-toys"/>
		</svg>
		<span class='screen-reader-text'>9to5Toys</span></a></li>
</li>

<li class='menu-item-dronedj'><a href='https://dronedj.com'><div class="ninetofive-icon ninetofive-dronedj"></div><span class='screen-reader-text'>DroneDJ</span></a></li>
</li>

<li><a href='https://spaceexplored.com'>		<svg class="ninetofive-icon spaceexplored-logo " aria-hidden="true">
									<use
				xlink:href="https://electrek.co/wp-content/themes/9to5-2015/images/svg-sprite-2020.svg#ninetofive-icon-spaceexplored-logo"/>
		</svg>
		<span class='screen-reader-text'>Space Explored</span></a></li>
</li>

<li class='site-switcher-text-only'><a href='/about'>About</a></li>
</li>

<li class='site-switcher-text-only'><a href='https://9to5mac.com/privacy/'>Privacy</a></li>
</li>
</ul>				</div>
				<!-- .site-switcher -->

			</header>
			<!-- .site-header -->

			<div class="site-header-placeholder"></div>
			
			<div class="order-control">
				
				
				<div class="th00598ad7 ad-container ad-container--leaderboard order-control__mobile-top">
					<div id="div-gpt-ad-1436850350386-0" class="inlinead"></div>
<script type='text/javascript'>
	// Make sure that nineto5ads exists, it will load ad once google tag exists
	window.nineto5ads = window.nineto5ads|| [];

	var apstagSlots = [];
	var adUnits = [];
	if ( 'undefined' !== typeof ninetofiveGetHeaderBidderAdUnits ) {
		adUnits = ninetofiveGetHeaderBidderAdUnits( "\/1049447\/Electrek-728x90-TopMain-R", [[728,90]], true );
	}
	apstagSlots.push( {
		slotID: "div-gpt-ad-1436850350386-0",
		slotName: "\/1049447\/Electrek-728x90-TopMain-R",
		sizes: [[728,90]]
	} );

	var slotID = "\/1049447\/Electrek-728x90-TopMain-R";</script>				</div>

					<div id="div-gpt-ad-signal" style="width: 0; height: 0;">
		<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-signal'); });
		</script>
	</div>
				</div><!-- .order-control -->
			
		<div id="content">
		

					<div class="news-feed-header">
				<div class="elastic-container">
					<div class="currently-reading">
						<p>Today</p>
					</div><!-- .currently-reading -->


				</div><!-- .elastic-container -->
			</div><!-- .news-feed-header -->
			<div id="news-placeholder"></div>

		<article class="post-content" itemscope itemtype="http://schema.org/NewsArticle">
				<div class="elastic-container">
					<h1 class="post-title" itemprop="headline"><a href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/" itemprop="mainEntityOfPage">Don&#8217;t miss these Black Friday deals from EcoFlow, offering as much as $650 off</a></h1>
					<div class="post-meta">
						<p class="byline" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<a href="https://electrek.co/author/sponsoredpostz/">
								<span itemprop="name">Sponsored Post</span>
							</a>
						</p>
						<p class="time-twitter">
							- Nov. 10th 2021 2:15 pm PT
						</p>


							<div class="tags">
								<div class="post-cats">
										<a href="https://electrek.co/feature/sponsored-post/" title="View all posts in Sponsored Post" class="featured_tag">Sponsored Post</a>
								</div><!-- .post-cats -->
							</div><!-- .tags -->

						<meta itemprop="keywords" content=""/>
						<meta itemprop="datePublished" content="2021-11-10 14:15:30"/>
						<meta itemprop="dateModified" content="2021-11-10 14:15:31"/>
					</div><!-- .post-meta -->
				</div><!-- .elastic-container -->
				<div class="feat-image-wrapper">
						<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
							<meta itemprop="url" content="https://electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?quality=82&#038;strip=all&#038;w=1600">
							<meta itemprop="height" content="920">
							<meta itemprop="width" content="1600">
						</div>
						<div class="feat-image wide js-single-top-img">
							<img src="https://electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?quality=82&#038;strip=all&#038;w=1600" srcset="https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=320&amp;quality=82&amp;strip=all&amp;ssl=1 320w, https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=640&amp;quality=82&amp;strip=all&amp;ssl=1 640w, https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=1024&amp;quality=82&amp;strip=all&amp;ssl=1 1024w, https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=1500&amp;quality=82&amp;strip=all&amp;ssl=1 1500w, https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=2000&amp;quality=82&amp;strip=all&amp;ssl=1 2000w, https://i0.wp.com/electrek.co/wp-content/uploads/sites/3/2021/10/BF-KV第二版第五次修改.jpg?w=2500&amp;quality=82&amp;strip=all&amp;ssl=1 2500w" width="1600" height="920" loading="lazy">
						</div><!-- .feat-image -->
					<div class="post-social-mobile">
						<a href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/#comments" class="comments" itemprop="discussionUrl"><span class="dsq-postid" data-dsqidentifier="201494 https://electrek.co/?p=201494">0</span></a>
						<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-201494" class="share-facebook sd-button share-icon" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-201494" class="share-twitter sd-button share-icon" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-201494" class="share-pinterest sd-button share-icon" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-201494" class="share-linkedin sd-button share-icon" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div>
					</div><!-- .post-social-mobile -->
				</div><!-- .feat-image-wrapper -->
				<div class="elastic-container">

					<div class="post-body" itemprop="articleBody">
						<p>As we sit amidst the cool air of autumn, another holiday season fast approaches. While certain terrains may begin to become tough to explore for the remainder of 2021, that doesn&#8217;t mean you can&#8217;t start planning all your off-grid adventures in 2022. With the seasons changing, you&#8217;ll also want to ensure that you&#8217;ve got backup power readily available for anything the elements throw at you. What better way to stay prepared than to take advantage of some <a href="https://bit.ly/3jJCln9" rel="sponsored nofollow">Black Friday deals from EcoFlow</a>? The company is currently offering a slew of substantial discounts on its Portable Power Stations and Solar Panels. Check them out below.</p>
<p><span id="more-201494"></span></p>
<div class="wp-block-yoast-seo-table-of-contents yoast-table-of-contents">
<h2>Table of contents</h2>
<ul>
<li><a href="#h-ecoflow-river-pro-portable-power-station" data-level="2">EcoFlow RIVER Pro Portable Power Station</a></li>
<li><a href="#h-ecoflow-delta-mini-portable-power-station" data-level="2">EcoFlow DELTA mini Portable Power Station</a></li>
<li><a href="#h-ecoflow-delta-portable-power-station" data-level="2">EcoFlow DELTA Portable Power Station</a></li>
<li><a href="#h-ecoflow-delta-max-portable-power-station" data-level="2">EcoFlow DELTA Max Portable Power Station</a></li>
<li><a href="#h-delta-bundle-ecoflow-delta-power-station-2-x-160w-solar-panels" data-level="2">DELTA Bundle: EcoFlow DELTA Power Station + 2 x 160W Solar Panels</a></li>
</ul>
</div>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205221" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-river-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow River Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205221 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205221" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-river-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow River Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205221" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<h2 id="h-ecoflow-river-pro-portable-power-station"><meta charset="utf-8"/>EcoFlow RIVER Pro Portable Power Station</h2>
<p>EcoFlow&#8217;s RIVER Pro power station picks up exactly where the standard RIVER left off and truly earns the &#8220;Pro&#8221; title in its name. It&#8217;s available at a Black Friday discounted price of <strong>$549</strong> <a href="https://bit.ly/3uGNXfa" rel="sponsored nofollow">through EcoFlow</a> or <a href="https://amzn.to/3BbUMYj" rel="sponsored nofollow">Amazon</a>, and comes equipped with a battery capacity of 720Wh, (430Wh more than the standard EcoFlow RIVER). You can even add a <a href="https://bit.ly/3jIfdp1" rel="sponsored nofollow">RIVER Pro Extra Battery</a> to double that capacity to 1,440Wh! </p>
<p>In addition to offering a high-capacity portable battery for any off-grid adventure, the EcoFlow RIVER Pro can power up to 10 devices at once and recharge from 0-80% in under an hour. Despite its significantly higher capacity battery, the RIVER Pro can quickly recharge in a number of ways:</p>
<ul>
<li>AC outlet: 96 minutes</li>
<li>Solar power: 4-8 hours</li>
<li>12V car outlet: 8 hours</li>
</ul>
<p>At 16.8 pounds, the Eco Flow RIVER Pro offers portable power on the go, delivering spare energy no matter where you are.</p>
<p>For Black Friday, the EcoFlow RIVER Pro Portable Power Station is currently&nbsp;<strong>$549&nbsp;</strong>(Reg. $649)&nbsp;<a href="https://bit.ly/3uGNXfa" rel="sponsored nofollow">from EcoFlow</a>&nbsp;or&nbsp;<a href="https://amzn.to/3BbUMYj" rel="sponsored nofollow">Amazon</a>.</p>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205222" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-river-pro-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-River-Pro-Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt class="wp-image-205222 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205222" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-river-pro-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-River-Pro-Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="" class="wp-image-205222" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-River-Pro-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<h2 id="h-ecoflow-delta-mini-portable-power-station"><meta charset="utf-8"/>EcoFlow DELTA mini <meta charset="utf-8"/>Portable Power Station</h2>
<p>Don&#8217;t let the &#8220;mini&#8221; in its name fool you, there is nothing small about the EcoFlow DELTA Mini&#8217;s 882Wh capacity. Currently available at a special Black Friday price of <strong>$849</strong> on <a href="https://bit.ly/3Aar8S6" rel="sponsored nofollow">the EcoFlow website</a>, or on <a href="https://amzn.to/3A7Dg6f" rel="sponsored nofollow">Amazon</a>, the DELTA mini offers versatile power storage in a smaller footprint. </p>
<p>The lightest of the DELTA models, weighing in at 23.6 pounds, the mini still delivers a significant capacity to keep you powered during power outages, outdoor adventures, remote work, and more. If you were looking at the EcoFlow RIVER and thought powering 10 devices wasn&#8217;t enough, the DELTA mini can handle 12 through an array of wall-style outlets, USB ports, and DC outlets.</p>
<p>Need to recharge your EcoFlow DELTA Mini on the go? No problem. The mini can garner 300W from <a href="https://bit.ly/3jDfOZ1" rel="sponsored nofollow">EcoFlow solar panels</a> to fully recharge in 3 to 6 hours. If you&#8217;re near a traditional AC outlet, the mini can replenish from 0-100% in just 96 minutes. </p>
<p>Get a DELTA mini for yourself or a loved one at EcoFlow&#8217;s exclusive Black Friday price of <strong>$849</strong> (Reg. $999), available on the <a href="https://bit.ly/3Aar8S6" rel="sponsored nofollow">EcoFlow website</a> or on <a href="https://amzn.to/3A7Dg6f" rel="sponsored nofollow">Amazon</a>.</p>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205223" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-mini-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow DELTA Mini Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt class="wp-image-205223 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205223" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-mini-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow DELTA Mini Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="" class="wp-image-205223" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Mini-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<h2 id="h-ecoflow-delta-portable-power-station"><meta charset="utf-8"/>EcoFlow DELTA <meta charset="utf-8"/>Portable Power Station</h2>
<p>Next in EcoFlow&#8217;s DELTA lineup is the standard DELTA portable power station. EcoFlow has taken $300 off the MSRP for Black Friday, so it&#8217;s currently priced at <strong>$1,099</strong> on both the <a href="https://bit.ly/3DfAPAF" rel="sponsored nofollow">EcoFlow website</a> and <a href="https://amzn.to/3mrYFSX">Amazon</a>.</p>
<p>As we move through the DELTA lineup, you&#8217;ll notice improvements to capacity and capabilities in power storage, whether it&#8217;s for outdoor excursions, power for professional work, or support during a power outage or natural disaster. No matter the application, the EcoFlow DELTA can deliver via its 1,260Wh capacity – capable of powering 13 devices at once. </p>
<p>This includes six AC outlets totaling 1,800W – that&#8217;s enough output to power most home appliances or heavy-duty tools. The EcoFlow&nbsp;DELTA offers every port you’ll need to power any device, no matter where you are. </p>
<p>Despite its large capacity, the DELTA still delivers speedy recharge times synonymous with the EcoFlow name. In fact, DELTA can juice up from 0-100% in just 1.6 hours. That&#8217;s roughly ten times faster than most other portable power stations on the market.</p>
<p>Interested in experiencing DELTA for yourself? EcoFlow&#8217;s Black Friday price of <strong>$1,099</strong> (Reg. $1,399) is a great opportunity to get your hands on one. They&#8217;re currently available through <a href="https://bit.ly/3DfAPAF" rel="sponsored nofollow">EcoFlow</a> or <a href="https://amzn.to/3mrYFSX" rel="sponsored nofollow">Amazon</a>.</p>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205232" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-DELTA-Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt class="wp-image-205232 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205232" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-DELTA-Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="" class="wp-image-205232" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<h2 id="h-ecoflow-delta-max-portable-power-station"><meta charset="utf-8"/>EcoFlow DELTA Max <meta charset="utf-8"/>Portable Power Station</h2>
<p>This Black Friday, push your backup power to its absolute ceiling with the EcoFlow DELTA Max portable power station. Right out of the gate, the DELTA Max delivers 2kWh of capacity for a current discounted price of <strong>$1,899</strong> through <a href="https://bit.ly/3Fh3UNS" rel="sponsored nofollow">EcoFlow</a> or <a href="https://amzn.to/3BcijZ8" rel="sponsored nofollow">Amazon</a>, but there&#8217;s the capability for more.</p>
<p>What&#8217;s unique to the DELTA Max is the ability to expand its power capacity to a whopping 6kWh (6,048 Wh) via EcoFlow&#8217;s <a href="https://bit.ly/3miVJsP" rel="sponsored nofollow">DELTA Max Smart Extra Batteries</a>. This level of additional storage delivers peace of mind on top of dependable power that can support your house lights and appliances during a blackout for hours upon hours. </p>
<p>EcoFlow didn&#8217;t just design this portable power station for power outages. By utilizing EcoFlow’s X-Boost technology, the DELTA Max can power heavy-duty devices up to 3,400W. This power station can also rapidly replenish from 0-80% of its 2kWh capacity in just 65 minutes. </p>
<p>Experience the pinnacle of EcoFlow&#8217;s DELTA line with the DELTA Max, currently available as part of the Black Friday deal priced at <strong>$1,899</strong> (Reg. $2,099) on the <a href="https://bit.ly/3Fh3UNS" rel="sponsored nofollow">EcoFlow website</a> or on <a href="https://amzn.to/3BcijZ8" rel="sponsored nofollow">Amazon</a>. <meta charset="utf-8"/></p>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205224" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-max-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-DELTA-Max-Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205224 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205224" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-delta-max-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-DELTA-Max-Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205224" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-DELTA-Max-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<h2 id="h-delta-bundle-ecoflow-delta-power-station-2-x-160w-solar-panels">DELTA Bundle: EcoFlow DELTA Power Station + 2 x 160W Solar Panels</h2>
<p>If you&#8217;re looking for the best Black Friday deal from EcoFlow, this bundle holds the crown. EcoFlow is currently offering $650 off this package that includes a DELTA power station and two 160W Solar Panels – priced for <strong>$1,649</strong> on both the <a href="https://bit.ly/3EB8aXi" rel="sponsored nofollow">EcoFlow store</a> and <a href="https://amzn.to/2YqLqKf" rel="sponsored nofollow">Amazon</a>.</p>
<p>In addition to obtaining the power from the EcoFlow DELTA outlined above, you&#8217;ll also receive two 160W Solar Panels, each delivering a high conversion efficiency of 21-22%. Each 160W Solar Panel is portable, foldable, and light – weighing in around 15.4 lbs (7kg).</p>
<p>By purchasing this Black Friday bundle, you&#8217;ll be able to combine both 160W Solar Panels with the EcoFlow DELTA portable power station. This offers improved solar recharge capabilities in cold and cloudy environments – perfect for the impending winter season and beyond. </p>
<p>Depending on the weather, you will be able to fully recharge your new DELTA power station in 5 to 10 hours using solar alone, offering you more mobility as you&#8217;ll no longer have to depend on an AC or 12V outlet to replenish your power storage. <meta charset="utf-8"/></p>
<p>As part of its Black Friday deals, EcoFlow is offering this bundle for only <meta charset="utf-8"/><strong>$1,649</strong> (Reg. $2,299), available through <a href="https://bit.ly/3EB8aXi" rel="sponsored nofollow">EcoFlow</a> or <a href="https://amzn.to/2YqLqKf" rel="sponsored nofollow">Amazon</a>.</p>
<figure class="wp-block-image alignwide size-large"><img data-attachment-id="205230" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-bundle-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-Bundle-Woods" data-image-description data-image-caption data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205230 jetpack-lazy-image" data-lazy-srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=290,145 290w" data-lazy-sizes="(max-width: 2000px) 100vw, 2000px" data-lazy-src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=1000&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="205230" data-permalink="https://electrek.co/2021/11/10/portable-battery-black-friday-deals-ecoflow/ecoflow-bundle-woods/" data-orig-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all" data-orig-size="2000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EcoFlow-Bundle-Woods" data-image-description="" data-image-caption="" data-medium-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=300" data-large-file="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" title="Don&#039;t miss these Black Friday deals from EcoFlow, offering as much as $650 off" loading="lazy" width="2000" height="1000" src="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?quality=82&amp;strip=all&amp;w=1000" alt="EcoFlow Black Friday" class="wp-image-205230" srcset="https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg 2000w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=150,75 150w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=300,150 300w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=768,384 768w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1024,512 1024w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1536,768 1536w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=350,175 350w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=1600,800 1600w, https://electrek.co/wp-content/uploads/sites/3/2021/10/EcoFlow-Bundle-Woods.jpg?resize=290,145 290w" sizes="(max-width: 2000px) 100vw, 2000px" /></noscript></figure>
<div class="ad-disclaimer-container"><p class="disclaimer-affiliate"><em>FTC: We use income earning auto affiliate links.</em> <a href="https://electrek.co/about/#affiliate">More.</a></p><!-- post ad --></div><div id="after_disclaimer_placement"></div><hr />
<p style="text-align: center"><a href="https://www.youtube.com/channel/UCcOIZzJgLCyMPILY7-1Vsdg?sub_confirmation=1">Subscribe to Electrek on YouTube for exclusive videos</a> and subscribe to the <a href="https://www.electrek.co/guides/electrek-podcast">podcast</a>.<!-- youtube embed --><div class="fluid-width-video-wrapper"><iframe title="Recent Videos" src="https://www.youtube.com/embed/8Ioh_tZ2rNY?playlist=3pLNFwpPCT4,u78Gw9hDVPg,suoEHfeNzzA,FiV5GwDatmc,NtbX_XeoRDU,v4bLE52ZzMk,I4c9rey6clU,w-ZFaarhlVI,TUo8AFW1ghY" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen width="1000" height="563"></iframe></div>
					</div><!-- .post-body -->


						<div class="visitor-promo" data-nosnippet="true">You’re reading Electrek— experts who break news about <a href="https://electrek.co/guides/tesla/">Tesla</a>, <a href="https://electrek.co/best-electric-vehicle-prices/">electric vehicles,</a> and <a href="https://electrek.co/guides/egeb/">green energy</a>, day after day. Be sure to check out our <a href="https://electrek.co/">homepage</a> for all the latest news, and follow Electrek on <a href="http://twitter.com/electrekco">Twitter</a>, <a href="https://www.facebook.com/electrekco/">Facebook</a>, and <a href="https://www.linkedin.com/company/electrek">LinkedIn</a> to stay in the loop. Don’t know where to start? Check out our <a href="https://youtube.com/c/electrekco">YouTube channel</a> for the latest reviews.</div>
				</div><!-- .elastic-container -->

				<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://electrek.co/wp-content/uploads/sites/3/2018/10/cropped-new-electrek-logo.png">
						<meta itemprop="width" content="288">
						<meta itemprop="height" content="60">
					</div>
					<meta itemprop="name" content="Electrek">
				</div>

				<div class="elastic-container">
					<div class="related-guides-container">
						<h1>Guides</h1>
						<div class="related-guides-list">
							<div class="related-guides-item">
								<a href="https://electrek.co/guides/sponsored-post/">
								<div class="related-guides-item-image">
									<img src="https://electrek.co/wp-content/themes/9to5-2015/images/default-electrek-guide.jpg" title="Sponsored Post" alt="Sponsored Post" loading="lazy" />
								</div>
								<h3>Sponsored Post</h3>
								<p></p>
								</a>
							</div>
							<div class="related-guides-item">
								<a href="https://electrek.co/guides/ecoflow/">
								<div class="related-guides-item-image">
									<img src="https://electrek.co/wp-content/themes/9to5-2015/images/default-electrek-guide.jpg" title="EcoFlow" alt="EcoFlow" loading="lazy" />
								</div>
								<h3>EcoFlow</h3>
								<p></p>
								</a>
							</div>
						</div>
							<div class="post-cats"></div>
							<!-- .post-cats -->
					</div>
				</div>

			<div class="elastic-container">
				<div class="author-bio-container">
					<h2 class="bio-title">About the Author</h2>
					<div class="author-bio" itemprop="author" itemscope itemtype="https://schema.org/Person">
							<div class="author-bio-details">
								<a href="https://electrek.co/author/sponsoredpostz/">
									<img src="https://secure.gravatar.com/avatar/85700b4b3b5d6089c388df52d53a7fcc?s=128&#038;d=identicon&#038;r=g" class="author-gravatar" loading="lazy">
								</a>
								<h3>
									<a href="https://electrek.co/author/sponsoredpostz/">
										<span itemprop="name">Sponsored Post</span>
									</a>
								</h3>


								<div class="author-excerpt">
									
								</div>
						</div>
					</div>
				</div>
			</div>




				<div class="ad-container ad-container--river"><div id="div-gpt-ad-1437016474156-0-201494" class="inlinead"></div></div>

		</article><!-- .post-content -->

	<aside class="trending-wrapper"><div class="trending-items trending-items--single">
				<a href="https://electrek.co/2021/11/09/elon-musk-linked-massive-land-grab-next-tesla-gigafactory-austin/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://electrek.co/wp-content/uploads/sites/3/2021/04/Tesla-cybertruck-gigafactory-texas.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Elon Musk linked to a massive land grab in Austin</p>
					</div>
				</a>
			
				<a href="https://electrek.co/2021/11/10/rivian-rivn-goes-public-70-billion-valuation-aims-reach-1-million-ev-volume-2030/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://electrek.co/wp-content/uploads/sites/3/2021/05/Rivian-r1t-electric-pickup.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Rivian goes public at $77 billion valuation</p>
					</div>
				</a>
			
				<a href="https://electrek.co/2021/11/09/bmw-begins-full-production-of-its-75-mph-ce-04-futuristic-electric-motorbike/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://electrek.co/wp-content/uploads/sites/3/2021/07/bmw-ce04-header.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">BMW begins production of its CE 04 e-motorbike</p>
					</div>
				</a>
			
				<a href="https://electrek.co/2021/11/10/juiced-bikes-unveils-ripracer-a-fun-sized-fat-tire-electric-bike-with-apple-airtag-battery-tracking/" rel="bookmark">
					<div class="trending-grid-item">
						<div class="img-wrap" style="background-image: url(https://electrek.co/wp-content/uploads/sites/3/2021/11/juiced-ripracer-debut-header.jpg?quality=82&#038;strip=all&#038;w=1600);"></div>
						<p class="trending-excerpt">Juiced RipRacer: a &#039;fun-sized,&#039; low-cost 28 mph e-bike</p>
					</div>
				</a>
			</div></aside>
					<div id="comments" class="comments-area post-body">
				<div class="elastic-container">
					
<div id="disqus_thread"></div>
				</div><!-- .elastic-container -->
			</div><!-- #comments.comments-area -->
			</div><!-- #content -->


	<div style="text-align:center">
		<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=electrek.co" rel="generator nofollow" class="powered-by-wpcom"><img src="https://electrek.co/wp-content/mu-plugins/vip-helpers/images/vip-powered-light-small.png" width="187" height="26" alt="Powered by WordPress VIP" /></a>	</div>

		<script type="text/javascript">
		//<![CDATA[
		var ninetofiveInfiniteScroll = {"settings":{"id":"content","ajaxurl":"https:\/\/electrek.co\/?infinity=scrolling","currentday":"10.11.21","order":"DESC","offset":0,"history":{"host":"electrek.co","path":"\/2021\/11\/10\/portable-battery-black-friday-deals-ecoflow\/page\/%d\/","use_trailing_slashes":true,"parameters":""},"query_args":{"page":0,"year":2021,"monthnum":11,"day":10,"name":"portable-battery-black-friday-deals-ecoflow","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":false,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":48,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"last_post_date":"2021-11-10 14:15:30","dfp_id":"1049447","post_id":201494,"stats":"blog=147888724&host=electrek.co&v=ext&j=1:10.3&x_pagetype=infinite-jetpack","google_analytics":false}};
		//]]>
	</script>
		<script async src="https://cdn.9to5terminal.com/push.js"></script>
		<script id='loop-template' type='x-tmpl-mustache'>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</script><script id='content-template' type='x-tmpl-mustache'><div class="extended">
	{{{ post_content }}}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}
	
	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .extended -->
</script><script id='aside-template' type='x-tmpl-mustache'><div class="post-body">

	{{# featured_image }}
		{{# product_link }}
			{{# product_price }}
				<div class="product_cta_image">
					<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
						{{# savings_amount }}
							<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
						{{/ savings_amount }}
						<span class="product-price">{{ product_price }}</span>
					</a>
				</div>
			{{/ product_price }}
		{{/ product_link }}

		<div class="feat-image-wrapper">
			{{# featured_image }}
				<div class="feat-image{{ image_class }}"><img src="{{featured_image}}" srcset="{{ srcset }}" loading="lazy"></div>
			{{/ featured_image }}
		</div><!-- .feat-image-wrapper -->
		<div class="post-social-mobile">
			<a href="{{permalink}}#comments" class="comments">{{{comment_count}}}</a>
			{{{share_buttons}}}
		</div><!-- .post-social-mobile -->

	{{/ featured_image }}
	{{{post_content}}}
	{{# meta.display_author_ad }}
		{{{ meta.author_ad }}}
	{{/ meta.display_author_ad }}

	{{# product_link }}
		{{# product_price }}
			<div class="product_cta_lower">
				<a href="{{ product_link }}" class="product-button{{# savings_amount }} has-savings{{/ savings_amount }}" target="_blank">
					{{# savings_amount }}
						<span class="product-savings-amount">Get this deal<br/>{{ savings_amount }}</span>
					{{/ savings_amount }}
					<span class="product-price">{{ product_price }}</span>
				</a>
			</div>
		{{/ product_price }}
	{{/ product_link }}

	<div class="post-cats">
		{{# featured_tags }}
    	<a href="{{tag_link}}" title="View all posts in {{tag_name}}" class="featured_tag">{{tag_name}}</a>
    {{/ featured_tags }}
		{{# categories }}
			<a href="{{cat_link}}" title="View all posts in {{cat_name}}">{{cat_name}}</a>
		{{/ categories }}
	</div><!-- .post-cats -->

	<div class="extended-comment-cta">
	  <a href="{{ permalink }}#comments" class="comments">{{{ comment_count }}}</a>
	</div>

</div><!-- .post-body -->
</script>		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<div id="jp-carousel-comment-form-commenting-as">
												<p id="jp-carousel-commenting-as">
													You must be <a href="#" class="jp-carousel-comment-login">logged in</a> to post a comment.												</p>
											</div>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
					<script>
		var options = {
			saveInCookies: true, // default: true,
			autoMatchOsTheme: true // default: true
		}

		const darkmode = new Darkmode(options);
	</script>
<link rel='stylesheet' id='all-css-0' href='https://electrek.co/_static/??-eJydzEsKwzAMRdENRZGD3cxK1+LYIriVP1gWobsvHWQaaIfvPjh4NAi1DCoDs0Jj3VMRfNJoPrxgMbPFXKMyCY7EFGH3zNTfV2sOIhP+IAffqwoxypEaddi0RKb/mfM9w1d65Puy2ptz1hnzAUOqWdc=' type='text/css' media='all' />
<script id='mediaelement-js-extra'>
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
</script>
<script id='ninetofive-js-extra'>
var globalJSVars = {"ajaxurl":"https:\/\/electrek.co\/wp-admin\/admin-ajax.php"};
</script>
<script id='disqus_count-js-extra'>
var countVars = {"disqusShortname":"electrek"};
</script>
<script id='disqus_embed-js-extra'>
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"201494 https:\/\/electrek.co\/?p=201494","disqusShortname":"electrek","disqusTitle":"Don\u2019t miss these Black Friday deals from EcoFlow, offering as much as $650 off","disqusUrl":"https:\/\/electrek.co\/2021\/11\/10\/portable-battery-black-friday-deals-ecoflow\/","postId":"201494"};
</script>
<script id='pushup-js-extra'>
var PushUpNotificationSettings = {"domain":"https:\/\/electrek.co","userID":"1","websitePushID":"web.co.electrek","webServiceURL":"https:\/\/push.10up.com","prompt":"1"};
</script>
<script type="text/javascript" src="https://electrek.co/_static/??-eJyVjkGOwjAMRS9EMDBqUReIo6BpYsBV4oTYBsHpAcGiEiBmdn/x3tOHU3E+syIr6B4TCnSaG7eYzRv4FUEVGARSDliZLtVl02I6HWQCf1OZGDVv6YjTRPwPkXhLTIpOfM0xulKxp/AuUqLtiAUCycEEivWR/D3hc0o3YOOz8cvnrxamHsMnq5jsrdzxxxr/IvbRAsoo5iqWeH5C67Satz9t03bdcjZcASNNjaY=" ></script><script src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?ver=1.1.2' id='ninetofive-google-adsense-js'></script>
<script type="text/javascript" src="https://electrek.co/wp-content/themes/9to5-2015/assets/js/vendor/stickybits.min.js?m=1635274499g" ></script><script id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script src='https://electrek.co/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/electrek.co\/wp-content\/mu-plugins\/jetpack-10.3\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/electrek.co\/wp-admin\/admin-ajax.php","nonce":"36cb2ddd24","display_exif":"0","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/electrek.co\/wp-login.php?redirect_to=https%3A%2F%2Felectrek.co%2F2021%2F11%2F10%2Fportable-battery-black-friday-deals-ecoflow%2F","blog_id":"3","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type="text/javascript" src="https://electrek.co/_static/??-eJy1kOFKBDEMhF/Ibu44XLkf4qNItg01a9ouTXrH+fRWT48V5FDBf5lM5hsIHBfH2UsLpDArJAqMJJQo2xfhEseKRkPiPMx6A9eC3VvrdcaXbO/s5hZpkXNPky3on912M+wgldCkI48cIpmCElb/9NZwntzZ+CnuQDmUCtisJDRjf7EFX06OE8ZeFlgNuJOqkjcu2ZVJqR6o/kPPavHdI7ukNFH4zdMeOwCmxhLAWCi4iCJUT9fUH/kea2lKcjn4XHzwHtL9dtyNt+N+f7eZXwHvRd/N" ></script>
	<script>
		(function($){
			$(document.body).on('post-load', function(){
				var nodes = document.querySelectorAll('span.dsq-postid');
				for (var i = 0, url; i < nodes.length; i++) {
					var shorturl = nodes[i].getAttribute('rel');
					var new_rel = shorturl ? shorturl.replace( 'https:', 'http:' ) : '';
					nodes[i].parentNode.setAttribute('data-disqus-identifier', new_rel );
					url = nodes[i].parentNode.href.split('#', 1);
					if (url.length == 1) url = url[0];
					else url = url[1];
					nodes[i].parentNode.href = url + '#disqus_thread';
				}

				var DISQUSWIDGETS = window.DISQUSWIDGETS || {};

				if ( Object.keys(DISQUSWIDGETS).length !== 0 && DISQUSWIDGETS.constructor === Object ) {
					DISQUSWIDGETS.getCount({reset: true});
				}
			});
		})(jQuery);
	</script>

	<script type='text/javascript'>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</script>
<script src='https://stats.wp.com/e-202145.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'147888724',post:'201494',tz:'-8',srv:'electrek.co'} ]);
	_stq.push([ 'clickTrackerInit', '147888724', '201494' ]);
</script>
<!-- Tracking Codes -->		<script type="text/javascript">
			var vglnk = {key: '1a191e4b4fb604347e07a98f5714a295'};
			(function(d, t) {
				var s = d.createElement(t);
				s.type = 'text/javascript';
				s.async = true;
				s.src = '//cdn.viglink.com/api/vglnk.js';
				var r = d.getElementsByTagName(t)[0];
				r.parentNode.insertBefore(s, r);
			}(document, 'script'));
		</script>
		<!-- End Tracking Codes -->
	</body>
</html>